smarty error

Smarty error, a forum discussion on Jojo CMS. Join us for more discussions on Smarty error on our Installation forum.

Back to Forum Index : Back to Installation   RSS

1 Jun 2012
Posts: 5

I just downloaded jojo and did the install. Everything went fine up to the point where you visit the new homepage or admin area. When either of those links are followed from the install program, I get this message ;
Fatal error: Cannot redeclare class Dwoo_Smarty_Adapter in /mnt/stor2-wc1-dfw1/409045/ on line 510
Any suggestions?

1 Jun 2012
Posts: 5

After reading some posts, I tried changing the template engine to smarty in the options table. That did the trick.
Rick Rick

1 Jun 2012
Posts: 336

Hi bengiles, welcome to the forum. Glad to hear that you got the problem sorted.

Dwoo is the the primary template engine now and not everything gets fully tested in Smarty so it'd be great to figure out what was going wrong.

What version of Jojo are you using? It looks like the SVN Trunk, is that right? The SVN Trunk was never stable, it was being pushed ahead fairly fast at the time but has since been superseded.

You might find better luck (and lots more features) with v1.1 from Github? Or the master branch if you're keen?

3 Jun 2012
Posts: 5

Thanks for the reply Rick. I was doing that install on a shared server to check it out. I deleted that account and have set up a couple of open stack servers at I did not make it as far on the installs I tried to do this time. I followed all the instructions and everything went fine up to the point where I copied and pasted the content for the .htaccess file. The next screen asks for the location of the core jojo files. The form already has the correct path filled in. This is what that page shows;

Jojo basedir

Enter the location of your core Jojo files.
Jojo Base Directory: /var/www/jojo

Please set the Jojo base directory above.

Jojo has been detected in the following locations:


When I click on next I get the 404 error;

The requested URL /install was not found on this server.
Apache/2.2.15 (CentOS) Server at Port 80

From your response to my post, it seems that maybe I should be using a different version anyway. I have 1.0rc2 according to the version file. Please advise, and thanks.

Rick Rick

3 Jun 2012
Posts: 336

Some shared hosts can't handle the PHP config lines that're in the .htaccess file. Also, have you made sure that mod_rewrite for Apache enabled?

Not sure exactly what version you're running, we're a little slow at updating the version file sometimes. Your best berry is to grab the 1.1 tag or 1.0 branch. We've recently moved to Github.

Edit: Fixed link tag.

3 Jun 2012
Posts: 5

I will download that and check on the mod_rewrite status. Thanks for the advice.

4 Jun 2012
Posts: 5

hello again. I tried installing version 1.1 and making sure that mod_rewrite was enabled and still get the same error message when i try to tell jojo where the core files are. The error--
The requested URL /install was not found on this server.
Apache/2.2.15 (CentOS) Server at Port 80

I tried setting up another server and putting all the files in the html directory. That is by directory where content goes. In filezilla it shows the path is-- var/www/html
I am running centos 6 on this server. I tried installing wordpress on the server to see if I had something set wrong on the server and had no problems at all installing wp.
I did put a phpinfo.php file there. I really like jojo for a lot of reasons and want to use it. As stated earlier I had installed it on a shared server and had no problem. These are cloud servers with root access that I am working with now. Any help getting jojo installed would be greatly appreciated. To verify my php set up go to



5 Jun 2012
Posts: 379

Hi Ben, what if you bypass the install process by creating the htaccess and config files manually (in the public directory where index.php is sitting)?

the htaccess file is usually generic - unless you are using a subfolder domain for testing in which case you need to include the subfolders in Rewrite base
eg if you are testing a site that has it's root at
then set RewriteBase /test/2/

# Jojo .htaccess file.
# Version 1740
RewriteEngine On

RewriteBase /

# Prevent PHP Session IDs showing up in the url
php_value session.use_only_cookies 1
php_value session.use_trans_sid 0

# Catch all requests
RewriteRule ^$ index.php?uri= [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?uri=$1

Likewise the config file is pretty straightforward

/* Database Connection */
define('_DBHOST', 'localhost');
define('_DBUSER', 'example');
define('_DBPASS', 'pass');
define('_DBNAME', 'exampledb');
/* Directory locations */
define('_SITEURL', '');
define('_BASEDIR', '/var/www/jojo/tags/1.1');
define('_WEBDIR', '/var/www/public_html');
define('_MYSITEDIR', '/var/www/mysite');
/* Debug Options - not recommended for production installations */
define('_DEBUG', false);
/* Master password */
define('_MASTERPASS', 'password');
/* Admin root */
define('_ADMIN', 'admin');

then run setup at
If that doesn't work then it suggests something more fundamental is getting in the way than just Jojo being unable to find itself - maybe read permissions on the Jojo folder?
Back to Forum Index : Back to Installation   RSS
You must be logged in to post a reply

You need to Register or Log In before posting on these forums.